How do you suppress the Price option when posting a not for sale painting?

I’ve been uploading paintings I’ve sold on commission and elsewhere just so I have a complete website of my paintings. I use the “Not for Sale” option but when I view the painting after it’s posted it says “Price: Contact Artist for Price”. Does anyone know of a way to suppress that?

Should not be doing that. I use the NFS option a lot due to commissions and it should be showing up Not For Sale. Maybe you should contact the Help Desk.

Thanks Elizabeth. I will try that.

There was a bug with the NSF status that allowed the price or the “contact artist” message to display. It has been fixed.